JailbreakMe broken: Apple updates iPhone, iPad iOS to thwart PDF vulnerability

Apple has just pushed new updates; iOS 4.0.2 for the iPhone and iPod touch, and iOS 3.2.2 for iPads. The update does what we all expected, takes away any jailbreaking fun you were having with JailbreakMe, but also protects you from the latest PDF security hole.

Apple’s official words: “Fixes security vulnerability associated with viewing malicious PDF files.”

There is nothing really new to this update aside from the security fix. So if you are interested in keeping your iDevice jailbroken your best bet is to skip this update until the jailbreakers have updated their own code – if they can.  Updated devices visiting the JailbreakMe.com website will show the error message of a “Version too old.” regardless of you using the latest update.


Posted in: Uncategorized

3 Comments

  1. kamil says:

    My iphone does not connect to itunes anymore, Cydia doesnt work and half of my apps dont work anymore. I start an app and the App just closes itself. im on version 2.2.1 with a modem firmware being 05.05.04_G, does anyone have any tips??

    Appreciated

    cheers

  2. ben says:

    happened to me now. what do i do? help Please….

  3. john says:

    if you have it jailbroken, just download the PDF exploit fix, there you go

Leave a Comment